fix delete_edit optimize segv, add dump submenu/dump_undo, add dbl edge drag/drop...
[goodguy/cinelerra.git] / cinelerra-5.1 / blds / debian / rules
1 #!/usr/bin/make -f
2 # from topdir ./debian/rules binary
3 package=cin
4
5 # Enable hardening flags
6 CFLAGS += $(shell dpkg-buildflags --get CFLAGS)
7 CXXFLAGS += $(shell dpkg-buildflags --get CXXFLAGS)
8 LDFLAGS += $(shell dpkg-buildflags --get LDFLAGS)
9
10 build build-arch build-indep: build-stamp
11
12 build-stamp:
13         dh_testdir
14         @if [ ! -e configure ] ; then ./autogen.sh; fi
15         CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" \
16                 ./configure --enable-opengl --prefix=/usr $(CONFFLAGS)
17         $(MAKE) $(MAKEFLAGS)
18         touch $@
19
20 clean:
21         dh_testdir
22         dh_testroot
23         [ ! -f Makefile ] || $(MAKE) clean
24         dh_clean -a
25         -rm -f build-stamp
26
27 install: build
28         dh_testdir
29         dh_testroot
30         dh_prep
31         dh_installdirs
32         $(MAKE) install DESTDIR=$(CURDIR)/debian/cin
33         install -D -m644 debian/sysctl.d debian/cin/etc/sysctl.d/50-cin.conf
34
35 binary-indep: build install
36
37 binary-arch: build install
38         dh_testdir
39         dh_testroot
40         dh_install
41         dh_link -a
42         dh_icons -a
43         dh_fixperms -a
44         dh_installdeb -a
45         dh_gencontrol 
46         dh_builddeb -p cin
47
48 binary: binary-indep binary-arch
49