no longer need ffmpeg patch0 which was for Termux
[goodguy/cinelerra.git] / cinelerra-5.1 / Makefile.am
index a61379cf3528f160d035ffe7c7ee21d139baf7b0..4214a9acb059956971c17e47c9fc5ed5c7190f52 100644 (file)
@@ -10,7 +10,7 @@ AM_MAKEFLAGS := -j$(WANT_JOBS)
 AUTOMAKE_OPTIONS=foreign
 ACLOCAL_AMFLAGS = -I m4
 
-SUBDIRS = thirdparty libzmpeg3 mpeg2enc mplexlo \
+SUBDIRS = thirdparty libbthread-master libzmpeg3 mpeg2enc mplexlo  \
        db guicast cinelerra plugins doc po db/utils
 
 BUILT_SOURCES := bin
@@ -32,8 +32,8 @@ export mkinstalldirs install_sh inst_sh
 
 # install to bin
 bin_install:   install-recursive
-       cp -a COPYING README models Cinelerra_factory expanders.txt \
-               ffmpeg msg info tips lv2_blacklist.txt bin/.
+       cp -a COPYING README models Cinelerra_factory expanders.* \
+               shuttlerc ffmpeg msg info tips lv2_blacklist.txt bin/.
        sed -e 's/\<cin\>/$(WANT_CIN)/g' < image/cin.desktop \
                > "bin/applications/$(WANT_CIN).desktop"
        cp -a image/cin.svg "bin/pixmaps/$(WANT_CIN)".svg
@@ -43,7 +43,7 @@ bin_install:  install-recursive
          if [ $$d = picon/cinfinity ]; then continue; fi; \
          cp -a $$d bin/plugins/picon/.; \
        done
-       -cp -a db/utils/new_db "bin/cin_db"
+       test ! -f db/utils/new_db || cp -a db/utils/new_db "bin/cin_db"
 
 bin_uninstall:
        rm -rf bin
@@ -52,8 +52,8 @@ bin_uninstall:
 sys_install: $(CIN_INSTALLS)
        cd bin; $(inst_sh) "$(DESTDIR)$(bindir)" "$(WANT_CIN)" bdwrite
        cd bin; $(inst_sh) "$(DESTDIR)$(datadir)/$(WANT_CIN)" \
-               COPYING README models Cinelerra_factory expanders.txt \
-               ffmpeg msg info tips doc
+               COPYING README models Cinelerra_factory expanders.* \
+               shuttlerc ffmpeg msg info tips doc
        cd bin/locale; $(inst_sh) "$(DESTDIR)$(localedir)" .
        cd bin/plugins; $(inst_sh) "$(DESTDIR)$(WANT_PLUGIN_DIR)" .
        cd bin/applications; $(inst_sh) "$(DESTDIR)$(datadir)/applications" .
@@ -61,6 +61,7 @@ sys_install: $(CIN_INSTALLS)
 
 sys_uninstall: $(CIN_UNINSTALLS)
        rm -f "$(DESTDIR)$(bindir)/$(WANT_CIN)"
+       rm -f "$(DESTDIR)$(bindir)/bdwrite"
        rm -rf "$(DESTDIR)$(WANT_CINLIB_DIR)"
        rm -rf "$(DESTDIR)$(datadir)/$(WANT_CIN)"
        rm -rf "$(DESTDIR)$(localedir)"/*/"LC_MESSAGES/$(WANT_CIN).mo"
@@ -78,12 +79,12 @@ dvl_uninstall:
 # with-libzmpeg3
 zmp_install:
        cd bin; $(inst_sh) "$(DESTDIR)$(bindir)" \
-               zmpeg3{cat,cc2txt,ifochk,show,toc}
+               zmpeg3{cc2txt,ifochk}
        cd bin; $(inst_sh) "$(DESTDIR)$(WANT_CINLIB_DIR)" \
                hveg2enc mpeg2enc mplex mplexlo
 
 zmp_uninstall:
-       rm -f "$(DESTDIR)$(bindir)"/zmpeg3{cat,cc2txt,ifochk,show,toc}
+       rm -f "$(DESTDIR)$(bindir)"/zmpeg3{cc2txt,ifochk}
 
 # with-commercial
 com_install: