no longer need ffmpeg patch0 which was for Termux
[goodguy/cinelerra.git] / cinelerra-5.1 / Makefile.am
index bd5c0f84379e42f4424bd11efb6261d181e3c62f..4214a9acb059956971c17e47c9fc5ed5c7190f52 100644 (file)
@@ -10,7 +10,7 @@ AM_MAKEFLAGS := -j$(WANT_JOBS)
 AUTOMAKE_OPTIONS=foreign
 ACLOCAL_AMFLAGS = -I m4
 
-SUBDIRS = thirdparty libzmpeg3 mpeg2enc mplexlo \
+SUBDIRS = thirdparty libbthread-master libzmpeg3 mpeg2enc mplexlo  \
        db guicast cinelerra plugins doc po db/utils
 
 BUILT_SOURCES := bin
@@ -43,7 +43,7 @@ bin_install:  install-recursive
          if [ $$d = picon/cinfinity ]; then continue; fi; \
          cp -a $$d bin/plugins/picon/.; \
        done
-       -cp -a db/utils/new_db "bin/cin_db"
+       test ! -f db/utils/new_db || cp -a db/utils/new_db "bin/cin_db"
 
 bin_uninstall:
        rm -rf bin
@@ -79,12 +79,12 @@ dvl_uninstall:
 # with-libzmpeg3
 zmp_install:
        cd bin; $(inst_sh) "$(DESTDIR)$(bindir)" \
-               zmpeg3{cat,cc2txt,ifochk,show,toc}
+               zmpeg3{cc2txt,ifochk}
        cd bin; $(inst_sh) "$(DESTDIR)$(WANT_CINLIB_DIR)" \
                hveg2enc mpeg2enc mplex mplexlo
 
 zmp_uninstall:
-       rm -f "$(DESTDIR)$(bindir)"/zmpeg3{cat,cc2txt,ifochk,show,toc}
+       rm -f "$(DESTDIR)$(bindir)"/zmpeg3{cc2txt,ifochk}
 
 # with-commercial
 com_install: