version update
[goodguy/cinelerra.git] / cinelerra-5.1 / blds / PKGBUILD
index fda0194d0d20b8c10398f80c0a115b9b2a865476..a985c2de853d2a2d165a77ad6b129dfdde8cd215 100644 (file)
@@ -1,29 +1,29 @@
-# Maintainer: goodguy <lists.cinelerra-cv.org>
+# Maintainer: goodguy <lists.cinelerra-gg.org>
 pkgname=cin
 pkgver=5.1
-pkgrel=20181031
-pkgdesc="Cinelerra git://git.cinelerra-cv.org/goodguy/cinelerra.git ($pkgrel)"
+pkgrel=20200430
+pkgdesc="Cinelerra git://git.cinelerra-gg.org/goodguy/cinelerra.git ($pkgrel)"
 arch=('x86_64')
-url="http://www.cinelerra-cv.org"
+url="https://www.cinelerra-gg.org"
 license=('GPL')
 DEPENDS=( 'alsa-lib' 'atk' 'bzip2' 'cairo' 'expat' 'fftw' 'flac'
  'fontconfig' 'freetype2' 'fribidi' 'gcc-libs' 'gdk-pixbuf2'
  'glib2' 'glibc' 'glu' 'graphite' 'gtk2' 'harfbuzz' 'libavc1394'
  'libdatrie' 'libdv' 'libffi' 'libglvnd' 'libiec61883' 'libjpeg-turbo'
- 'libogg' 'libpng' 'libraw1394' 'libsndfile' 'libthai'
- 'libtheora' 'libtiff' 'libutil-linux' 'libvdpau' 'libvorbis'
+ 'libogg' 'libpng' 'libraw1394' 'libsndfile' 'libthai' 'libusb'
+ 'libtheora' 'libtiff' 'libutil-linux' 'libvdpau' 'libva' 'libvorbis'
  'libvpx' 'libx11' 'libxau' 'libxcb' 'libxcomposite' 'libxcursor'
  'libxdamage' 'libxdmcp' 'libxext' 'libxfixes' 'libxft' 'libxi'
  'libxinerama' 'libxrandr' 'libxrender' 'libxv' 'numactl' 'opus'
- 'pango' 'pcre' 'pixman' 'xz' 'zlib' 'xorg-server' 'libva'
+ 'pango' 'pcre' 'pixman' 'xz' 'zlib' 'xorg-server' 'libpulse'
  'xorg-fonts-misc' 'ttf-dejavu' 'inkscape' 'dvdauthor' 'udftools' )
 
-makedepends=( 'autoconf' 'automake' 'yasm' 'nasm' 'cmake'
+makedepends=( 'autoconf' 'automake' 'yasm' 'nasm' 'cmake' 'libtool'
         'libxml2' 'perl-xml-libxml' 'perl-xml-parser'
         'xorg-mkfontdir' 'xorg-mkfontscale' )
 
 conflicts=()
-source=(https://www.cinelerra-cv.org/five/pkgs/src/cin_$pkgver.$pkgrel-src.tgz)
+source=(https://www.cinelerra-gg.org/download/pkgs/src/cin_$pkgver.$pkgrel-src.tgz)
 md5sums=('00000000000000000000000000000000')
 
 prepare() {
@@ -34,7 +34,6 @@ prepare() {
 build() {
   cd "$srcdir/cinelerra-$pkgver"
   ./autogen.sh
-  export FFMPEG_EXTRA_CFG=" --disable-vdpau"
   ./configure --prefix=/usr --with-exec-name=$pkgname
 CFG_VARS="\
 CFLAGS+=' -Wno-narrowing -O2 -g -fno-omit-frame-pointer' \