oops again - update configure for v3.2.0
[goodguy/cinelerra.git] / cinelerra-5.1 / configure.ac
index 7702a6b3460af1913079e2d68d7968e334921bc0..9ecd9c87a6b15404d9a62bdf79d7706e5fc66a3f 100644 (file)
@@ -53,7 +53,7 @@ CHECK_WITH([git-ffmpeg],[git ffmpeg using url],[GIT_FFMPEG],[no])
 CHECK_WITH([noelision],[use noelision/libpthread],[NOELISION],[auto])
 CHECK_WITH([booby],[window lock trace booby trap],[BOOBY],[no])
 CHECK_WITH([libzmpeg],[build libzmpeg],[LIBZMPEG],[yes])
-CHECK_WITH([commercial],[enable commercial capture],[COMMERCIAL],[yes])
+CHECK_WITH([commercial],[enable commercial capture],[COMMERCIAL],[no])
 CHECK_WITH([thirdparty],[use thirdparty build],[CIN_3RDPARTY],[yes])
 CHECK_WITH([shuttle],[shuttle device],[SHUTTLE],[yes])
 CHECK_WITH([wintv],[usb 2040:826d wintv device],[WINTV],[yes])
@@ -189,7 +189,7 @@ PKG_3RD([esound],[no],
   [ . ])
 
 PKG_3RD([ffmpeg],[yes],
-  [ffmpeg-4.2],
+  [ffmpeg-4.4],
   [ libavutil/libavutil.a \
     libavcodec/libavcodec.a \
     libpostproc/libpostproc.a \
@@ -234,19 +234,11 @@ PKG_3RD([flac],[auto],
   [ include ])
 
 PKG_3RD([giflib],[yes],
-  [giflib-5.1.6],
-  [ libgif.a ],
+  [giflib-5.2.1],
+  [ libgif.a \
+    libutil.a ],
   [ . ])
 
-PKG_3RD([ilmbase],[auto],
-  [ilmbase-2.2.1],
-  [ Iex/.libs/libIex.a \
-    IexMath/.libs/libIexMath.a \
-    Half/.libs/libHalf.a \
-    Imath/.libs/libImath.a \
-    IlmThread/.libs/libIlmThread.a ],
-  [ Iex Half Imath config IlmThread ])
-
 PKG_DEF([ladspa], [ladspa-0.4.17], [], [])
 
 PKG_3RD([lame],[auto],
@@ -278,24 +270,23 @@ PKG_3RD([libdv],[auto],
   [ . ])
 
 PKG_3RD([libjpeg],[auto],
-  [libjpeg-turbo-1.5.1],
-  [ .libs/libjpeg.a \
-    .libs/libturbojpeg.a \
-    simd/.libs/libsimd.a ],
-  [ . ])
+  [libjpeg-turbo-2.1.0],
+  [ build/libjpeg.a \
+    build/libturbojpeg.a ],
+  [ opt/libjpeg-turbo/include ])
 
 PKG_3RD([opus],[auto],
-  [opus-1.3],
+  [opus-1.3.1],
   [ .libs/libopus.a ],
   [ include ])
 
 PKG_3RD([openjpeg],[auto],
-  [openjpeg-2.3.0],
+  [openjpeg-2.4.0],
   [ bin/libopenjp2.a ],
   [ src/lib/openjp2 ])
 
 PKG_3RD([libogg],[auto],
-  [libogg-1.3.3],
+  [libogg-1.3.4],
   [ src/.libs/libogg.a ],
   [ include ])
 
@@ -312,7 +303,7 @@ PKG_3RD([libtheora],[auto],
   [ lib/.libs/libtheora.a \
     lib/.libs/libtheoradec.a \
     lib/.libs/libtheoraenc.a ],
-  [ . ])
+  [ include ])
 
 PKG_3RD([libuuid],[yes],
   [libuuid-1.0.3],
@@ -320,7 +311,7 @@ PKG_3RD([libuuid],[yes],
   [ . ])
 
 PKG_3RD([libvorbis],[auto],
-  [libvorbis-1.3.6],
+  [libvorbis-1.3.7],
   [ lib/.libs/libvorbis.a \
     lib/.libs/libvorbisenc.a \
     lib/.libs/libvorbisfile.a ],
@@ -338,10 +329,18 @@ PKG_3RD([mjpegtools],[yes],
   [ .  lavtools utils ])
 
 PKG_3RD([openexr],[auto],
-  [openexr-2.2.1],
-  [ IlmImf/.libs/libIlmImf.a \
-    IlmImfUtil/.libs/libIlmImfUtil.a ],
-  [ IlmImf config ])
+  [openexr-2.4.1],
+  [ usr/local/lib/libHalf.a \
+    usr/local/lib/libIex.a \
+    usr/local/lib/libIexMath.a \
+    usr/local/lib/libIlmThread.a \
+    usr/local/lib/libImath.a \
+    usr/local/lib/libIlmImf.a \
+    usr/local/lib/libIlmImfUtil.a ],
+  [ usr/local/include/OpenEXR ])
+
+PKG_3RD([openExr],[auto], [openExr], [] [])
+PKG_3RD([ilmBase],[auto], [ilmBase], [] [])
 
 #PKG_3RD([festival],[no],
 #  [festival],
@@ -353,74 +352,74 @@ PKG_3RD([openexr],[auto],
 #  [])
 #
 PKG_3RD([tiff],[auto],
-  [tiff-4.0.10],
+  [tiff-4.1.0],
   [ libtiff/.libs/libtiff.a \
     libtiff/.libs/libtiffxx.a \
     port/.libs/libport.a ],[
    . ])
 
 PKG_3RD([twolame],[auto],
-  [twolame-0.3.13],
+  [twolame-0.4.0],
   [ libtwolame/.libs/libtwolame.a ],
   [  libtwolame ])
 
 PKG_3RD([x264],[auto],
-  [x264-snapshot-20190117-2245-stable],
+  [x264-snapshot-20210615-master],
   [ libx264.a ],
   [ . ])
 
 PKG_3RD([x265],[auto],
-  [x265_3.1.2],
+  [x265_3.5],
   [ libx265.a ],
   [ . source ])
 
 PKG_3RD([libvpx],[auto],
-  [libvpx-1.8.1],
+  [libvpx-1.8.2],
   [ libvpx.a ],
   [ . ])
 
 PKG_3RD([lv2],[auto],
-  [lv2-1.16.0],
+  [lv2-1.18.0],
   [ ],
   [ usr/local/include usr/local/lib64/lv2 usr/local/lib/lv2 ])
 
 PKG_3RD([sratom],[auto],
-  [sratom-0.6.2],
+  [sratom-0.6.4],
   [ usr/local/lib/libsratom-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([serd],[auto],
-  [serd-0.30.0],
+  [serd-0.30.4],
   [ usr/local/lib/libserd-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([sord],[auto],
-  [sord-0.16.2],
+  [sord-0.16.4],
   [ usr/local/lib/libsord-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([lilv],[auto],
-  [lilv-0.24.4],
+  [lilv-0.24.8],
   [ usr/local/lib/liblilv-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([suil],[auto],
-  [suil-0.10.2],
+  [suil-0.10.6],
   [ usr/local/lib/libsuil-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([libaom],[auto],
-  [libaom-v1.0.0],
+  [libaom-v3.2.0],
   [ usr/local/lib*/libaom*.a ],
   [ usr/local/include ])
 
 PKG_3RD([dav1d],[auto],
-  [dav1d-0.5.0],
+  [dav1d-0.5.1],
   [ usr/local/lib*/libdav1d*.a ],
   [ usr/local/include ])
 
 PKG_3RD([libwebp],[auto],
-  [libwebp-1.0.2],
+  [libwebp-1.1.0],
   [ usr/local/lib*/libwebp*.a ],
   [ usr/local/include ])
 
@@ -556,20 +555,12 @@ CHECK_LIB([lame], [mp3lame], [lame_init])
 CHECK_HEADERS([lame], [lame headers], [lame/lame.h])
 CHECK_LIB([libjpeg], [jpeg], [jpeg_start_decompress])
 CHECK_HEADERS([libjpeg], [jpeg headers], [stdio.h jpeglib.h])
-CHECK_LIB([libogg], [ogg], [ogg_stream_init])
-CHECK_HEADERS([libogg], [ogg headers], [ogg/ogg.h])
 CHECK_LIB([openjpeg], [openjp2], [opj_version])
 CHECK_HEADERS([openjpeg], [openjpeg headers], [openjpeg.h])
 CHECK_LIB([libsndfile], [sndfile], [sf_open])
 CHECK_HEADERS([libsndfile], [sndfile headers], [sndfile.h])
 CHECK_LIB([ilmbase], [IlmImf], [ImfOpenInputFile])
 CHECK_HEADERS([ilmbase], [IlmImf headers], [OpenEXR/ImfCRgbaFile.h])
-CHECK_LIB([libtheora], [theora], [theora_info_init], [-ltheoraenc -ltheoradec -logg])
-CHECK_HEADERS([libtheora], [threora headers], [theora/theoraenc.h])
-CHECK_LIB([libvorbis], [vorbisenc], [vorbis_encode_init], [-lvorbis -lvorbisfile -logg])
-CHECK_HEADERS([libvorbis], [vorbis encoders headers], [vorbis/vorbisenc.h])
-CHECK_LIB([libvorbis], [vorbisfile], [ov_open])
-CHECK_HEADERS([libvorbis], [vorbis file headers], [vorbis/vorbisfile.h])
 CHECK_LIB([libvpx], [vpx], [vpx_codec_decode])
 CHECK_HEADERS([libvpx], [vpx headers], [vpx/vpx_decoder.h])
 CHECK_LIB([mjpegtools], [mjpegutils], [mjpeg_info])
@@ -623,20 +614,17 @@ fi
 AC_DEFUN([CHECK_WANT], [
 RESULT=yes
 # WANT_$1
-if test "x$WANT_$1" != "xno" ; then
 AC_ARG_WITH(m4_tolower([$1]),
  AC_HELP_STRING([m4_join([-],[--with],m4_tolower([$1]))], [$3] (auto)),
   [WANT_$1=$withval],[WANT_$1=$2])
  m4_quote($4)
- if test "x$RESULT" = "xno" -a "x$PKG_$1" = "x"; then
-  if test "x$WANT_$1" = "xyes" ; then
+ if test "x$WANT_$1" = "xauto" ; then
+  WANT_$1="$RESULT"
+ elif test "x$WANT_$1" = "xyes" ; then
+  if test "x$RESULT" = "xno" -a "x$PKG_$1" = "x"; then
     AC_MSG_ERROR([required for $1 support.])
   fi
-  WANT_$1=no
- elif test "x$WANT_$1" = "xauto" ; then
-  WANT_$1=yes
  fi
-fi
 CFG_WANTS+=" $1"
 AC_SUBST([WANT_$1])
 ])
@@ -661,6 +649,16 @@ CHECK_WANT([ALSA], [auto], [use libasound/alsa], [
  CHECK_LIB([ALSA], [asound], [snd_pcm_open])
  CHECK_HEADERS([ALSA], [asound headers], [alsa/asoundlib.h])])
 
+CHECK_WANT([OGG], [auto], [use ogg/theora/vorbis], [
+ CHECK_LIB([libogg], [ogg], [ogg_stream_init])
+ CHECK_HEADERS([libogg], [ogg headers], [ogg/ogg.h])
+ CHECK_LIB([libtheora], [theora], [theora_info_init], [-ltheoraenc -ltheoradec -logg])
+ CHECK_HEADERS([libtheora], [threora headers], [theora/theoraenc.h])
+ CHECK_LIB([libvorbis], [vorbisenc], [vorbis_encode_init], [-lvorbis -lvorbisfile -logg])
+ CHECK_HEADERS([libvorbis], [vorbis encoders headers], [vorbis/vorbisenc.h])
+ CHECK_LIB([libvorbis], [vorbisfile], [ov_open])
+ CHECK_HEADERS([libvorbis], [vorbis file headers], [vorbis/vorbisfile.h])])
+
 CHECK_WANT([FIREWIRE], [auto], [use firewire], [
  CHECK_LIB([libavc1394], [avc1394], [avc1394_init_target])
  CHECK_HEADERS([libavc1394], [libavc1394 headers], [libavc1394/avc1394.h])
@@ -670,6 +668,15 @@ CHECK_WANT([FIREWIRE], [auto], [use firewire], [
  CHECK_HEADERS([libiec61883], [libiec61883 headers], [libiec61883/iec61883.h])
  CHECK_LIB([libraw1394], [raw1394], [raw1394_iso_recv_init])
  CHECK_HEADERS([libraw1394], [libraw1394 headers], [libraw1394/raw1394.h])])
+# have all or none
+test "x$HAVE_libavc1394" = "xyes" && \
+test "x$HAVE_libiec61883" = "xyes" && \
+test "x$HAVE_libraw1394" = "xyes" && \
+  HAVE_FIREWIRE=yes || \
+HAVE_libavc1394=no \
+HAVE_libiec61883=no \
+HAVE_libraw1394=no \
+ HAVE_FIREWIRE=no
 
 CHECK_WANT([DV], [auto], [use dv], [
  CHECK_LIB([libdv], [dv], [dv_init])
@@ -689,6 +696,13 @@ CHECK_WANT([ESOUND], [no], [use esd], [
  CHECK_HEADERS([esound], [esound headers], [esd.h])
  CHECK_LIB([audiofile], [audiofile], [afOpenFile])
  CHECK_HEADERS([audiofile], [audiofile headers], [audiofile.h])])
+# have all or none
+test "x$HAVE_esound" = "xyes" && \
+test "x$HAVE_audiofile" = "xyes" && \
+  HAVE_ESOUND=yes || \
+HAVE_esound=no \
+HAVE_audiofile=no \
+  HAVE_ESOUND=no
 
 CHECK_WANT([PULSE], [auto], [use pulseaudio], [
  CHECK_LIB([pulse_simple], [pulse-simple], [pa_simple_new])
@@ -727,6 +741,21 @@ CHECK_WANT([LV2], [auto], [use lv2], [
  CFLAGS="-I/usr/include/suil-0 -I/usr/local/include/suil-0"
  CHECK_HEADERS([lv2], [suil headers], [suil/suil.h])
  CFLAGS="$saved_CFLAGS"])
+# have all or none
+test "x$HAVE_lv2" = "xyes" && \
+test "x$HAVE_lilv" = "xyes" && \
+test "x$HAVE_sord" = "xyes" && \
+test "x$HAVE_serd" = "xyes" && \
+test "x$HAVE_sratom" = "xyes" && \
+test "x$HAVE_suil" = "xyes" && \
+  HAVE_LV2=yes || \
+HAVE_lv2=no \
+HAVE_lilv=no \
+HAVE_sord=no \
+HAVE_serd=no \
+HAVE_sratom=no \
+HAVE_suil=no \
+  HAVE_LV2=no
 
 CHECK_WANT([CUDA], [auto], [build cuda plugins], [
   CHECK_HEADERS([CUDA], [cuda sdk], [${CUDA_PATH:-/usr/local/cuda}/include/cuda.h])])
@@ -764,11 +793,15 @@ EXRIStream() : Imf::IStream("mypath") {} };
 class EXROStream : public Imf::OStream { public: 
 EXROStream() : Imf::OStream("mypath") {} };
 ]])], [HAVE_OPENEXR=yes], [HAVE_OPENEXR=no])
- RESULT="$HAVE_OPENEXR"
- if test "x$RESULT" = "xyes"; then
-  SHARED_openexr="$LIBS"
-  SHARED_LIBS+=" $LIBS"
-  CFG_CFLAGS+=" -I/usr/include/OpenEXR -I/usr/local/include/OpenEXR"
+ if test "x$WANT_OPENEXR" = "xauto"; then
+   WANT_OPENEXR="yes"
+ fi
+ if test "x$WANT_OPENEXR" = "xyes" -a "x$HAVE_OPENEXR" = "xyes"; then
+  if test "x$WANT_STATIC_BUILD" = "xno"; then
+    SHARED_openexr="$LIBS"
+    SHARED_LIBS+=" $LIBS"
+    CFG_CFLAGS+=" -I/usr/include/OpenEXR -I/usr/local/include/OpenEXR"
+  fi
  fi
  LIBS="$saved_LIBS"
  CXXFLAGS="$saved_CXXFLAGS"
@@ -776,6 +809,13 @@ EXROStream() : Imf::OStream("mypath") {} };
  AC_MSG_RESULT([$HAVE_OPENEXR])
 ])
 AC_SUBST([HAVE_OPENEXR])
+# have all or none
+test "x$HAVE_openexr" = "xyes" && \
+test "x$HAVE_ilmbase" = "xyes" && \
+  HAVE_OPENEXR=yes || \
+HAVE_openexr=no \
+HAVE_ilmbase=no \
+  HAVE_OPENEXR=no
 
 # build global_config
 OBJDIR=`uname -m`
@@ -818,7 +858,7 @@ for dep in \
         openexr/ilmbase ilmbase/libogg \
         libtheora/libogg libtheora/libvorbis ; do
   lib=`dirname $dep`;  needs=`basename $dep`
-  eval pkg_lib="\$PKG_$lib"; eval needs_lib="\$HAVE_$needs";
+  eval pkg_lib="\$PKG_$lib"
   if test "x$pkg_lib" != "xno"; then
     eval "PKG_$needs=yes"
   fi
@@ -854,7 +894,7 @@ PKG_PROVIDE([ffmpeg])
 PKG_PROVIDE([fftw])
 PKG_PROVIDE([flac])
 PKG_PROVIDE([giflib])
-PKG_PROVIDE([ilmbase], [$WANT_OPENEXR])
+PKG_PROVIDE([ilmBase], [$WANT_OPENEXR])
 PKG_PROVIDE([ladspa],[$WANT_LADSPA_BUILD])
 PKG_PROVIDE([lame])
 PKG_PROVIDE([libavc1394],[$WANT_FIREWIRE])
@@ -871,6 +911,7 @@ PKG_PROVIDE([mjpegtools])
 PKG_PROVIDE([libaom])
 PKG_PROVIDE([dav1d])
 PKG_PROVIDE([libwebp])
+PKG_PROVIDE([openExr], [$WANT_OPENEXR])
 PKG_PROVIDE([openexr], [$WANT_OPENEXR])
 PKG_PROVIDE([openjpeg])
 PKG_PROVIDE([tiff])
@@ -908,7 +949,7 @@ echo ""
 if test "x$WANT_CIN_3RDPARTY" != "xno"; then
   CFG_CFLAGS+=" -DHAVE_CIN_3RDPARTY"
 fi
-for v in GL XFT XXF86VM OSS ALSA FIREWIRE DV DVB LADSPA \
+for v in GL XFT XXF86VM OSS ALSA FIREWIRE OGG DV DVB LADSPA \
         VIDEO4LINUX2 ESOUND PULSE PACTL OPENEXR LV2 \
         COMMERCIAL LIBZMPEG SHUTTLE SHUTTLE_USB XV \
         VAAPI VDPAU CUDA NV WINTV X10TV; do