add libbthread to main directory for Android from Andrew
[goodguy/cinelerra.git] / cinelerra-5.1 / libbthread-master / Makefile.am
diff --git a/cinelerra-5.1/libbthread-master/Makefile.am b/cinelerra-5.1/libbthread-master/Makefile.am
new file mode 100644 (file)
index 0000000..41724de
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright (C) 2002 Free Software Foundation, Inc.
+# This file is part of the GNU C Library.
+#
+# The GNU C Library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# The GNU C Library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with the GNU C Library; see the file COPYING.LIB.  If not,
+# write to the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+
+lib_LTLIBRARIES = libbthread.la
+libbthread_la_SOURCES = pt-cancel.c pt-docancel.c pt-init.c pt-setcancelstate.c pt-setcanceltype.c pt-testcancel.c pt-internal.h
+include_HEADERS = bthread.h
+check_PROGRAMS = bthread-test
+bthread_test_SOURCES = pt-test.c