18 new shapewipe transitions from rafa, rework savefile/confirm for nested edl edits
[goodguy/cinelerra.git] / cinelerra-5.1 / Makefile.am
index a61379cf3528f160d035ffe7c7ee21d139baf7b0..bd5c0f84379e42f4424bd11efb6261d181e3c62f 100644 (file)
@@ -32,8 +32,8 @@ export mkinstalldirs install_sh inst_sh
 
 # install to bin
 bin_install:   install-recursive
-       cp -a COPYING README models Cinelerra_factory expanders.txt \
-               ffmpeg msg info tips lv2_blacklist.txt bin/.
+       cp -a COPYING README models Cinelerra_factory expanders.* \
+               shuttlerc ffmpeg msg info tips lv2_blacklist.txt bin/.
        sed -e 's/\<cin\>/$(WANT_CIN)/g' < image/cin.desktop \
                > "bin/applications/$(WANT_CIN).desktop"
        cp -a image/cin.svg "bin/pixmaps/$(WANT_CIN)".svg
@@ -52,8 +52,8 @@ bin_uninstall:
 sys_install: $(CIN_INSTALLS)
        cd bin; $(inst_sh) "$(DESTDIR)$(bindir)" "$(WANT_CIN)" bdwrite
        cd bin; $(inst_sh) "$(DESTDIR)$(datadir)/$(WANT_CIN)" \
-               COPYING README models Cinelerra_factory expanders.txt \
-               ffmpeg msg info tips doc
+               COPYING README models Cinelerra_factory expanders.* \
+               shuttlerc ffmpeg msg info tips doc
        cd bin/locale; $(inst_sh) "$(DESTDIR)$(localedir)" .
        cd bin/plugins; $(inst_sh) "$(DESTDIR)$(WANT_PLUGIN_DIR)" .
        cd bin/applications; $(inst_sh) "$(DESTDIR)$(datadir)/applications" .
@@ -61,6 +61,7 @@ sys_install: $(CIN_INSTALLS)
 
 sys_uninstall: $(CIN_UNINSTALLS)
        rm -f "$(DESTDIR)$(bindir)/$(WANT_CIN)"
+       rm -f "$(DESTDIR)$(bindir)/bdwrite"
        rm -rf "$(DESTDIR)$(WANT_CINLIB_DIR)"
        rm -rf "$(DESTDIR)$(datadir)/$(WANT_CIN)"
        rm -rf "$(DESTDIR)$(localedir)"/*/"LC_MESSAGES/$(WANT_CIN).mo"