rest of Termux related mods from Andrew
[goodguy/cinelerra.git] / cinelerra-5.1 / Makefile.am
index 64e1e8dff3d0162796c61b022097f41b9ab62344..ea53b474a784e07af0dc912f9fc6e7cba497b662 100644 (file)
@@ -32,7 +32,7 @@ export mkinstalldirs install_sh inst_sh
 
 # install to bin
 bin_install:   install-recursive
-       cp -a COPYING README models Cinelerra_factory expanders.txt \
+       cp -a COPYING README models Cinelerra_factory expanders.* \
                shuttlerc ffmpeg msg info tips lv2_blacklist.txt bin/.
        sed -e 's/\<cin\>/$(WANT_CIN)/g' < image/cin.desktop \
                > "bin/applications/$(WANT_CIN).desktop"
@@ -43,7 +43,7 @@ bin_install:  install-recursive
          if [ $$d = picon/cinfinity ]; then continue; fi; \
          cp -a $$d bin/plugins/picon/.; \
        done
-       -cp -a db/utils/new_db "bin/cin_db"
+       test ! -f db/utils/new_db || cp -a db/utils/new_db "bin/cin_db"
 
 bin_uninstall:
        rm -rf bin
@@ -52,7 +52,7 @@ bin_uninstall:
 sys_install: $(CIN_INSTALLS)
        cd bin; $(inst_sh) "$(DESTDIR)$(bindir)" "$(WANT_CIN)" bdwrite
        cd bin; $(inst_sh) "$(DESTDIR)$(datadir)/$(WANT_CIN)" \
-               COPYING README models Cinelerra_factory expanders.txt \
+               COPYING README models Cinelerra_factory expanders.* \
                shuttlerc ffmpeg msg info tips doc
        cd bin/locale; $(inst_sh) "$(DESTDIR)$(localedir)" .
        cd bin/plugins; $(inst_sh) "$(DESTDIR)$(WANT_PLUGIN_DIR)" .
@@ -79,12 +79,12 @@ dvl_uninstall:
 # with-libzmpeg3
 zmp_install:
        cd bin; $(inst_sh) "$(DESTDIR)$(bindir)" \
-               zmpeg3{cat,cc2txt,ifochk,show,toc}
+               zmpeg3{cc2txt,ifochk}
        cd bin; $(inst_sh) "$(DESTDIR)$(WANT_CINLIB_DIR)" \
                hveg2enc mpeg2enc mplex mplexlo
 
 zmp_uninstall:
-       rm -f "$(DESTDIR)$(bindir)"/zmpeg3{cat,cc2txt,ifochk,show,toc}
+       rm -f "$(DESTDIR)$(bindir)"/zmpeg3{cc2txt,ifochk}
 
 # with-commercial
 com_install: