Credit Andrey for script and Andrew for configure mods
[goodguy/cinelerra.git] / cinelerra-5.1 / configure.ac
index bce24689930f2401a8a800285b49e50a1a2f8ee5..1329c96ce93854f819a510841a0f0749c3a6f683 100644 (file)
@@ -6,6 +6,7 @@ AC_INIT([cinelerra],[5.1],[mail@lists.cinelerra-gg.org])
 # externally. This macro must be set before calling AC_INIT_AUTOMAKE
 AC_CONFIG_AUX_DIR(m4)
 AM_INIT_AUTOMAKE([foreign])
+LT_INIT()
 
 AM_PROG_AS
 AC_LANG([C++])
@@ -23,6 +24,10 @@ if test x"$GETTEXT" == x"no" ; then
 AC_MSG_ERROR([Please install gettext])
 fi
 
+AC_CHECK_PROG(LIBTOOL,[libtool],[libtool],[no])
+if test x"$LIBTOOL" == x"no" ; then
+AC_MSG_ERROR([Please install libtool])
+fi
 
 CFG_CFLAGS+=" -fno-omit-frame-pointer -fno-math-errno -fno-signed-zeros"
 CFG_CFLAGS+=" -pthread -Wall"
@@ -217,7 +222,7 @@ PKG_3RD([esound],[no],
   [ . ])
 
 PKG_3RD([ffmpeg],[yes],
-  [ffmpeg-4.4],
+  [ffmpeg-5.1],
   [ libavutil/libavutil.a \
     libavcodec/libavcodec.a \
     libpostproc/libpostproc.a \
@@ -250,7 +255,7 @@ PKG_3RD([fftw],[auto],
   [ api ])
 
 PKG_3RD([flac],[auto],
-  [flac-1.3.2],
+  [flac-1.4.0],
   [ src/libFLAC/.libs/libFLAC.a \
     src/libFLAC++/.libs/libFLAC++.a \
     src/share/replaygain_analysis/.libs/libreplaygain_analysis.a \
@@ -400,7 +405,7 @@ PKG_3RD([ilmBase],[auto], [ilmBase], [] [])
 #  [])
 #
 PKG_3RD([tiff],[auto],
-  [tiff-4.3.0],
+  [tiff-4.4.0],
   [ libtiff/.libs/libtiff.a \
     libtiff/.libs/libtiffxx.a \
     port/.libs/libport.a ],[
@@ -422,7 +427,7 @@ PKG_3RD([x265],[auto],
   [ . source ])
 
 PKG_3RD([libvpx],[auto],
-  [libvpx-1.11.0],
+  [libvpx-1.12.0],
   [ libvpx.a ],
   [ . ])
 
@@ -457,7 +462,7 @@ PKG_3RD([suil],[auto],
   [ usr/local/include ])
 
 PKG_3RD([libaom],[auto],
-  [libaom-v3.2.0],
+  [libaom-v3.4.0],
   [ usr/local/lib*/libaom*.a ],
   [ usr/local/include ])
 
@@ -594,7 +599,7 @@ if test "x$HAVE_$1" != "xno"; then
 fi
 ])
 
-IMMATH_HEADERS=$(pkg-config --cflags Imath)
+IMMATH_HEADERS=$(pkg-config --cflags Imath 2>/dev/null)
 
 CHECK_LIB([X11], [X11], [XOpenDisplay])
 CHECK_HEADERS([X11], [X11 headers], [X11/X.h X11/Xlib.h X11/Xutil.h X11/cursorfont.h])
@@ -816,16 +821,16 @@ CHECK_WANT([LV2], [auto], [use lv2], [
  CHECK_LIB([sord], [sord-0], [sord_world_new])
  CHECK_LIB([serd], [serd-0], [serd_reader_new])
  CHECK_LIB([sratom], [sratom-0], [sratom_new])
- CFLAGS="-I/usr/include/lilv-0 -I/usr/local/include/lilv-0 `pkg-config --cflags lilv-0`"
+ CFLAGS="-I/usr/include/lilv-0 -I/usr/local/include/lilv-0 `pkg-config --cflags lilv-0 2>/dev/null`"
  CHECK_HEADERS([lilv], [lilv headers], [lilv/lilv.h])
- CFLAGS="-I/usr/include/serd-0 -I/usr/local/include/serd-0 `pkg-config --cflags serd-0`"
+ CFLAGS="-I/usr/include/serd-0 -I/usr/local/include/serd-0 `pkg-config --cflags serd-0 2>/dev/null`"
  CHECK_HEADERS([serd], [serd headers], [serd/serd.h])
- CFLAGS="-I/usr/include/sord-0 -I/usr/local/include/sord-0 `pkg-config --cflags sord-0`"
+ CFLAGS="-I/usr/include/sord-0 -I/usr/local/include/sord-0 `pkg-config --cflags sord-0 2>/dev/null`"
  CHECK_HEADERS([sord], [sord headers], [sord/sord.h])
- CFLAGS="-I/usr/include/sratom-0 -I/usr/local/include/sratom-0 `pkg-config --cflags sratom-0`"
+ CFLAGS="-I/usr/include/sratom-0 -I/usr/local/include/sratom-0 `pkg-config --cflags sratom-0 2>/dev/null`"
  CHECK_HEADERS([sratom], [sratom headers], [sratom/sratom.h])
  CHECK_LIB([suil], [suil-0], [suil_instance_new])
- CFLAGS="-I/usr/include/suil-0 -I/usr/local/include/suil-0 `pkg-config --cflags  suil-0`"
+ CFLAGS="-I/usr/include/suil-0 -I/usr/local/include/suil-0 `pkg-config --cflags  suil-0 2>/dev/null`"
  CHECK_HEADERS([suil], [suil headers], [suil/suil.h])
  CFG_CFLAGS+=" $(pkg-config --cflags lilv-0) $(pkg-config --cflags suil-0)"
  LIBS="$saved_LIBS"
@@ -1077,6 +1082,7 @@ done
 # build extras
 if test "x$WANT_CLANG" = "xyes" ; then
   FFMPEG_EXTRA_CFG+=' --cc=clang --cxx=clang++'
+  CFG_CFLAGS+=" -Wno-unknown-warning-option"
 fi
 if test "x$HAVE_tiff" = "xyes"; then
   if test "x$HAVE_jbig" = "xyes"; then