Credit libaom/libvpx teams and Andrew patch update
[goodguy/cinelerra.git] / cinelerra-5.1 / configure.ac
index 5ee692fc02ed7871751a10a1b482aa4e08439d0c..83d2465ec716f01609c5f963dca62045c4007c76 100644 (file)
@@ -12,6 +12,18 @@ AC_LANG([C++])
 AC_LANG([C])
 AC_PROG_CXX
 
+
+AC_CHECK_PROG(MAKEINFO,[makeinfo],[makeinfo],[no])
+if test x"$MAKEINFO" == x"no" ; then
+AC_MSG_ERROR([Please install texinfo])
+fi
+
+AC_CHECK_PROG(GETTEXT,[gettext],[gettext],[no])
+if test x"$GETTEXT" == x"no" ; then
+AC_MSG_ERROR([Please install gettext])
+fi
+
+
 CFG_CFLAGS+=" -fno-omit-frame-pointer -fno-math-errno -fno-signed-zeros"
 CFG_CFLAGS+=" -pthread -Wall"
 # misguided pedantic warnings
@@ -296,7 +308,7 @@ PKG_3RD([opus],[auto],
   [ include ])
 
 PKG_3RD([openjpeg],[auto],
-  [openjpeg-2.4.0],
+  [openjpeg-2.5.0],
   [ bin/libopenjp2.a ],
   [ src/lib/openjp2 ])
 
@@ -410,7 +422,7 @@ PKG_3RD([x265],[auto],
   [ . source ])
 
 PKG_3RD([libvpx],[auto],
-  [libvpx-1.11.0],
+  [libvpx-1.12.0],
   [ libvpx.a ],
   [ . ])
 
@@ -445,7 +457,7 @@ PKG_3RD([suil],[auto],
   [ usr/local/include ])
 
 PKG_3RD([libaom],[auto],
-  [libaom-v3.2.0],
+  [libaom-v3.4.0],
   [ usr/local/lib*/libaom*.a ],
   [ usr/local/include ])