even more Termux related mods by Andrew + MatN configure improvement
[goodguy/cinelerra.git] / cinelerra-5.1 / configure.ac
index a2d5b501a63ae120b6a3349809816660329362ed..996054f37991261d23604510ec99dc5dcae25f13 100644 (file)
@@ -12,7 +12,7 @@ CFG_CFLAGS+=" -fno-omit-frame-pointer -fno-math-errno -fno-signed-zeros"
 CFG_CFLAGS+=" -pthread -Wall"
 # misguided pedantic warnings
 #  this is extra work, not a gain...
-CFG_CFLAGS+=" -Wno-unknown-warning-option"
+#CFG_CFLAGS+=" -Wno-unknown-warning-option"
 CFG_CFLAGS+=" -Wno-attributes"
 CFG_CFLAGS+=" -Wno-unused-result"
 CFG_CFLAGS+=" -Wno-stringop-overflow"
@@ -26,7 +26,9 @@ CFG_CFLAGS+=" -DPNG_SKIP_SETJMP_CHECK=1"
 CFG_CFLAGS+=" -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
 CFG_CFLAGS+=" -I/usr/include -I/usr/local/include"
 CFG_CFLAGS+=" -I/usr/include/freetype2 -I/usr/local/include/freetype2"
+CFG_CFLAGS+=" -I/data/data/com.termux/files/usr/include/freetype2"
 CFG_CFLAGS+=" -I/usr/include/uuid -I/usr/local/include/uuid"
+CFG_CFLAGS+=" -I/data/data/com.termux/files/usr/include/uuid -I/usr/local/include/uuid"
 CFG_CFLAGS+=" -I/usr/include/mjpegtools -I/usr/local/include/mjpegtools"
 
 AC_DEFUN([CHECK_WITH], [
@@ -53,7 +55,7 @@ CHECK_WITH([git-ffmpeg],[git ffmpeg using url],[GIT_FFMPEG],[no])
 CHECK_WITH([noelision],[use noelision/libpthread],[NOELISION],[auto])
 CHECK_WITH([booby],[window lock trace booby trap],[BOOBY],[no])
 CHECK_WITH([libzmpeg],[build libzmpeg],[LIBZMPEG],[yes])
-CHECK_WITH([commercial],[enable commercial capture],[COMMERCIAL],[yes])
+CHECK_WITH([commercial],[enable commercial capture],[COMMERCIAL],[no])
 CHECK_WITH([thirdparty],[use thirdparty build],[CIN_3RDPARTY],[yes])
 CHECK_WITH([shuttle],[shuttle device],[SHUTTLE],[yes])
 CHECK_WITH([wintv],[usb 2040:826d wintv device],[WINTV],[yes])
@@ -140,7 +142,8 @@ AC_SUBST(MAK_INSTALLS)
 AC_SUBST(MAK_UNINSTALLS)
 
 if test "x$WANT_JOBS" = "xauto"; then
-  CPUS=`grep -c "^proc" /proc/cpuinfo`
+#  CPUS=`grep -c "^proc" /proc/cpuinfo`
+  CPUS=nproc
   WANT_JOBS=`expr $CPUS + $CPUS / 2 + 2`
 fi
 
@@ -189,7 +192,7 @@ PKG_3RD([esound],[no],
   [ . ])
 
 PKG_3RD([ffmpeg],[yes],
-  [ffmpeg-4.2],
+  [ffmpeg-4.4],
   [ libavutil/libavutil.a \
     libavcodec/libavcodec.a \
     libpostproc/libpostproc.a \
@@ -234,19 +237,11 @@ PKG_3RD([flac],[auto],
   [ include ])
 
 PKG_3RD([giflib],[yes],
-  [giflib-5.1.6],
-  [ libgif.a ],
+  [giflib-5.2.1],
+  [ libgif.a \
+    libutil.a ],
   [ . ])
 
-PKG_3RD([ilmbase],[auto],
-  [ilmbase-2.2.1],
-  [ Iex/.libs/libIex.a \
-    IexMath/.libs/libIexMath.a \
-    Half/.libs/libHalf.a \
-    Imath/.libs/libImath.a \
-    IlmThread/.libs/libIlmThread.a ],
-  [ Iex Half Imath config IlmThread ])
-
 PKG_DEF([ladspa], [ladspa-0.4.17], [], [])
 
 PKG_3RD([lame],[auto],
@@ -278,24 +273,23 @@ PKG_3RD([libdv],[auto],
   [ . ])
 
 PKG_3RD([libjpeg],[auto],
-  [libjpeg-turbo-1.5.1],
-  [ .libs/libjpeg.a \
-    .libs/libturbojpeg.a \
-    simd/.libs/libsimd.a ],
-  [ . ])
+  [libjpeg-turbo-2.1.0],
+  [ build/libjpeg.a \
+    build/libturbojpeg.a ],
+  [ opt/libjpeg-turbo/include ])
 
 PKG_3RD([opus],[auto],
-  [opus-1.3],
+  [opus-1.3.1],
   [ .libs/libopus.a ],
   [ include ])
 
 PKG_3RD([openjpeg],[auto],
-  [openjpeg-2.3.0],
+  [openjpeg-2.4.0],
   [ bin/libopenjp2.a ],
   [ src/lib/openjp2 ])
 
 PKG_3RD([libogg],[auto],
-  [libogg-1.3.3],
+  [libogg-1.3.4],
   [ src/.libs/libogg.a ],
   [ include ])
 
@@ -312,7 +306,7 @@ PKG_3RD([libtheora],[auto],
   [ lib/.libs/libtheora.a \
     lib/.libs/libtheoradec.a \
     lib/.libs/libtheoraenc.a ],
-  [ . ])
+  [ include ])
 
 PKG_3RD([libuuid],[yes],
   [libuuid-1.0.3],
@@ -320,12 +314,19 @@ PKG_3RD([libuuid],[yes],
   [ . ])
 
 PKG_3RD([libvorbis],[auto],
-  [libvorbis-1.3.6],
+  [libvorbis-1.3.7],
   [ lib/.libs/libvorbis.a \
     lib/.libs/libvorbisenc.a \
     lib/.libs/libvorbisfile.a ],
   [ include . ])
 
+## arch dep tests
+ARCH=[`uname -m`]
+I86=[`expr "x$ARCH" : 'xi[346]86.*'`]
+X86=[`expr "x$ARCH" : 'x..._64*'`]
+
+if test "x$I86$X86" != "x00" ; then
+
 PKG_3RD([mjpegtools],[yes],
   [mjpegtools-2.1.0],
   [ utils/mmxsse/.libs/libmmxsse.a \
@@ -337,11 +338,33 @@ PKG_3RD([mjpegtools],[yes],
     mpeg2enc/.libs/libmpeg2encpp.a ],
   [ .  lavtools utils ])
 
+else
+
+PKG_3RD([mjpegtools],[yes],
+  [mjpegtools-2.1.0],
+  [ utils/.libs/libmjpegutils.a \
+    lavtools/.libs/liblavfile.a \
+    lavtools/.libs/liblavjpeg.a \
+    mplex/.libs/libmplex2.a \
+    yuvfilters/.libs/libyuvfilters.a \
+    mpeg2enc/.libs/libmpeg2encpp.a ],
+  [ .  lavtools utils ])
+
+fi
+
 PKG_3RD([openexr],[auto],
-  [openexr-2.2.1],
-  [ IlmImf/.libs/libIlmImf.a \
-    IlmImfUtil/.libs/libIlmImfUtil.a ],
-  [ IlmImf config ])
+  [openexr-2.4.1],
+  [ usr/local/lib/libHalf.a \
+    usr/local/lib/libIex.a \
+    usr/local/lib/libIexMath.a \
+    usr/local/lib/libIlmThread.a \
+    usr/local/lib/libImath.a \
+    usr/local/lib/libIlmImf.a \
+    usr/local/lib/libIlmImfUtil.a ],
+  [ usr/local/include/OpenEXR ])
+
+PKG_3RD([openExr],[auto], [openExr], [] [])
+PKG_3RD([ilmBase],[auto], [ilmBase], [] [])
 
 #PKG_3RD([festival],[no],
 #  [festival],
@@ -353,74 +376,74 @@ PKG_3RD([openexr],[auto],
 #  [])
 #
 PKG_3RD([tiff],[auto],
-  [tiff-4.0.10],
+  [tiff-4.1.0],
   [ libtiff/.libs/libtiff.a \
     libtiff/.libs/libtiffxx.a \
     port/.libs/libport.a ],[
    . ])
 
 PKG_3RD([twolame],[auto],
-  [twolame-0.3.13],
+  [twolame-0.4.0],
   [ libtwolame/.libs/libtwolame.a ],
   [  libtwolame ])
 
 PKG_3RD([x264],[auto],
-  [x264-snapshot-20190117-2245-stable],
+  [x264-snapshot-20210615-master],
   [ libx264.a ],
   [ . ])
 
 PKG_3RD([x265],[auto],
-  [x265_3.1.2],
+  [x265_3.5],
   [ libx265.a ],
   [ . source ])
 
 PKG_3RD([libvpx],[auto],
-  [libvpx-1.8.1],
+  [libvpx-1.8.2],
   [ libvpx.a ],
   [ . ])
 
 PKG_3RD([lv2],[auto],
-  [lv2-1.16.0],
+  [lv2-1.18.0],
   [ ],
   [ usr/local/include usr/local/lib64/lv2 usr/local/lib/lv2 ])
 
 PKG_3RD([sratom],[auto],
-  [sratom-0.6.2],
+  [sratom-0.6.4],
   [ usr/local/lib/libsratom-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([serd],[auto],
-  [serd-0.30.0],
+  [serd-0.30.4],
   [ usr/local/lib/libserd-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([sord],[auto],
-  [sord-0.16.2],
+  [sord-0.16.4],
   [ usr/local/lib/libsord-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([lilv],[auto],
-  [lilv-0.24.4],
+  [lilv-0.24.8],
   [ usr/local/lib/liblilv-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([suil],[auto],
-  [suil-0.10.2],
+  [suil-0.10.6],
   [ usr/local/lib/libsuil-0.a ],
   [ usr/local/include ])
 
 PKG_3RD([libaom],[auto],
-  [libaom-v1.0.0],
+  [libaom-v3.2.0],
   [ usr/local/lib*/libaom*.a ],
   [ usr/local/include ])
 
 PKG_3RD([dav1d],[auto],
-  [dav1d-0.5.0],
+  [dav1d-0.5.1],
   [ usr/local/lib*/libdav1d*.a ],
   [ usr/local/include ])
 
 PKG_3RD([libwebp],[auto],
-  [libwebp-1.0.2],
+  [libwebp-1.1.0],
   [ usr/local/lib*/libwebp*.a ],
   [ usr/local/include ])
 
@@ -429,6 +452,15 @@ PKG_3RD([ffnvcodec],[auto],
   [ ],
   [ . ])
 
+if test [ "$(uname -o)"] = "Android"  ; then
+
+PKG_3RD([libbthread],[auto],
+  [libbthread-master],
+  [ *.a ],
+  [ . ])
+fi
+
+
 AC_SUBST(STATIC_PKGS)
 
 AC_DEFUN([CHECK_ENABLE], [
@@ -477,6 +509,10 @@ if test "x$I86$X86" != "x00" ; then
   REQUIRE_PROG(YASM, [yasm])
 fi
 
+if test "x$I86$X86" == "x00"; then
+   CFG_CFLAGS+=" -DNO_CTX -DNO_GDB -DNO_BTRACE"
+fi
+
 ## end arch dep tests
 
 REQUIRE_PROG(OBJCOPY, [objcopy])
@@ -556,20 +592,12 @@ CHECK_LIB([lame], [mp3lame], [lame_init])
 CHECK_HEADERS([lame], [lame headers], [lame/lame.h])
 CHECK_LIB([libjpeg], [jpeg], [jpeg_start_decompress])
 CHECK_HEADERS([libjpeg], [jpeg headers], [stdio.h jpeglib.h])
-CHECK_LIB([libogg], [ogg], [ogg_stream_init])
-CHECK_HEADERS([libogg], [ogg headers], [ogg/ogg.h])
 CHECK_LIB([openjpeg], [openjp2], [opj_version])
 CHECK_HEADERS([openjpeg], [openjpeg headers], [openjpeg.h])
 CHECK_LIB([libsndfile], [sndfile], [sf_open])
 CHECK_HEADERS([libsndfile], [sndfile headers], [sndfile.h])
 CHECK_LIB([ilmbase], [IlmImf], [ImfOpenInputFile])
 CHECK_HEADERS([ilmbase], [IlmImf headers], [OpenEXR/ImfCRgbaFile.h])
-CHECK_LIB([libtheora], [theora], [theora_info_init], [-ltheoraenc -ltheoradec -logg])
-CHECK_HEADERS([libtheora], [threora headers], [theora/theoraenc.h])
-CHECK_LIB([libvorbis], [vorbisenc], [vorbis_encode_init], [-lvorbis -lvorbisfile -logg])
-CHECK_HEADERS([libvorbis], [vorbis encoders headers], [vorbis/vorbisenc.h])
-CHECK_LIB([libvorbis], [vorbisfile], [ov_open])
-CHECK_HEADERS([libvorbis], [vorbis file headers], [vorbis/vorbisfile.h])
 CHECK_LIB([libvpx], [vpx], [vpx_codec_decode])
 CHECK_HEADERS([libvpx], [vpx headers], [vpx/vpx_decoder.h])
 CHECK_LIB([mjpegtools], [mjpegutils], [mjpeg_info])
@@ -658,6 +686,16 @@ CHECK_WANT([ALSA], [auto], [use libasound/alsa], [
  CHECK_LIB([ALSA], [asound], [snd_pcm_open])
  CHECK_HEADERS([ALSA], [asound headers], [alsa/asoundlib.h])])
 
+CHECK_WANT([OGG], [auto], [use ogg/theora/vorbis], [
+ CHECK_LIB([libogg], [ogg], [ogg_stream_init])
+ CHECK_HEADERS([libogg], [ogg headers], [ogg/ogg.h])
+ CHECK_LIB([libtheora], [theora], [theora_info_init], [-ltheoraenc -ltheoradec -logg])
+ CHECK_HEADERS([libtheora], [threora headers], [theora/theoraenc.h])
+ CHECK_LIB([libvorbis], [vorbisenc], [vorbis_encode_init], [-lvorbis -lvorbisfile -logg])
+ CHECK_HEADERS([libvorbis], [vorbis encoders headers], [vorbis/vorbisenc.h])
+ CHECK_LIB([libvorbis], [vorbisfile], [ov_open])
+ CHECK_HEADERS([libvorbis], [vorbis file headers], [vorbis/vorbisfile.h])])
+
 CHECK_WANT([FIREWIRE], [auto], [use firewire], [
  CHECK_LIB([libavc1394], [avc1394], [avc1394_init_target])
  CHECK_HEADERS([libavc1394], [libavc1394 headers], [libavc1394/avc1394.h])
@@ -672,9 +710,9 @@ test "x$HAVE_libavc1394" = "xyes" && \
 test "x$HAVE_libiec61883" = "xyes" && \
 test "x$HAVE_libraw1394" = "xyes" && \
   HAVE_FIREWIRE=yes || \
-HAVE_libavc1394=no && \
-HAVE_libiec61883=no && \
-HAVE_libraw1394=no && \
+HAVE_libavc1394=no \
+HAVE_libiec61883=no \
+HAVE_libraw1394=no \
  HAVE_FIREWIRE=no
 
 CHECK_WANT([DV], [auto], [use dv], [
@@ -699,8 +737,8 @@ CHECK_WANT([ESOUND], [no], [use esd], [
 test "x$HAVE_esound" = "xyes" && \
 test "x$HAVE_audiofile" = "xyes" && \
   HAVE_ESOUND=yes || \
-HAVE_esound=no && \
-HAVE_audiofile=no && \
+HAVE_esound=no \
+HAVE_audiofile=no \
   HAVE_ESOUND=no
 
 CHECK_WANT([PULSE], [auto], [use pulseaudio], [
@@ -748,12 +786,12 @@ test "x$HAVE_serd" = "xyes" && \
 test "x$HAVE_sratom" = "xyes" && \
 test "x$HAVE_suil" = "xyes" && \
   HAVE_LV2=yes || \
-HAVE_lv2=no && \
-HAVE_lilv=no && \
-HAVE_sord=no && \
-HAVE_serd=no && \
-HAVE_sratom=no && \
-HAVE_suil=no && \
+HAVE_lv2=no \
+HAVE_lilv=no \
+HAVE_sord=no \
+HAVE_serd=no \
+HAVE_sratom=no \
+HAVE_suil=no \
   HAVE_LV2=no
 
 CHECK_WANT([CUDA], [auto], [build cuda plugins], [
@@ -812,8 +850,8 @@ AC_SUBST([HAVE_OPENEXR])
 test "x$HAVE_openexr" = "xyes" && \
 test "x$HAVE_ilmbase" = "xyes" && \
   HAVE_OPENEXR=yes || \
-HAVE_openexr=no && \
-HAVE_ilmbase=no &&
+HAVE_openexr=no \
+HAVE_ilmbase=no \
   HAVE_OPENEXR=no
 
 # build global_config
@@ -884,6 +922,7 @@ if test "x$BUILD_$1" = "x" ; then
 fi
 ])
 
+PKG_PROVIDE([libbthread])
 PKG_PROVIDE([a52dec])
 PKG_PROVIDE([djbfft])
 PKG_PROVIDE([encore])
@@ -893,7 +932,7 @@ PKG_PROVIDE([ffmpeg])
 PKG_PROVIDE([fftw])
 PKG_PROVIDE([flac])
 PKG_PROVIDE([giflib])
-PKG_PROVIDE([ilmbase], [$WANT_OPENEXR])
+PKG_PROVIDE([ilmBase], [$WANT_OPENEXR])
 PKG_PROVIDE([ladspa],[$WANT_LADSPA_BUILD])
 PKG_PROVIDE([lame])
 PKG_PROVIDE([libavc1394],[$WANT_FIREWIRE])
@@ -910,6 +949,7 @@ PKG_PROVIDE([mjpegtools])
 PKG_PROVIDE([libaom])
 PKG_PROVIDE([dav1d])
 PKG_PROVIDE([libwebp])
+PKG_PROVIDE([openExr], [$WANT_OPENEXR])
 PKG_PROVIDE([openexr], [$WANT_OPENEXR])
 PKG_PROVIDE([openjpeg])
 PKG_PROVIDE([tiff])
@@ -947,7 +987,7 @@ echo ""
 if test "x$WANT_CIN_3RDPARTY" != "xno"; then
   CFG_CFLAGS+=" -DHAVE_CIN_3RDPARTY"
 fi
-for v in GL XFT XXF86VM OSS ALSA FIREWIRE DV DVB LADSPA \
+for v in GL XFT XXF86VM OSS ALSA FIREWIRE OGG DV DVB LADSPA \
         VIDEO4LINUX2 ESOUND PULSE PACTL OPENEXR LV2 \
         COMMERCIAL LIBZMPEG SHUTTLE SHUTTLE_USB XV \
         VAAPI VDPAU CUDA NV WINTV X10TV; do
@@ -1013,6 +1053,11 @@ if test "x$WANT_BOOBY" != "xno"; then
   CFG_CFLAGS+=" -DBOOBY"
 fi
 
+if test [ "$(uname -o)"] = "Android" ; then
+# termux
+EXTRA_LIBS+=' -liconv'
+fi
+
 # intel lock elision bugs
 if test "x$WANT_NOELISION" != "xno"; then
   CFG_RPATH=`ls -1fd 2> /dev/null \