minor corrections to plugin.opts
[goodguy/cinelerra.git] / cinelerra-5.1 / configure.ac
index 83d2465ec716f01609c5f963dca62045c4007c76..ab06ace919e39c05b831b723690f44ecb2f27391 100644 (file)
@@ -6,6 +6,7 @@ AC_INIT([cinelerra],[5.1],[mail@lists.cinelerra-gg.org])
 # externally. This macro must be set before calling AC_INIT_AUTOMAKE
 AC_CONFIG_AUX_DIR(m4)
 AM_INIT_AUTOMAKE([foreign])
+LT_INIT()
 
 AM_PROG_AS
 AC_LANG([C++])
@@ -23,6 +24,10 @@ if test x"$GETTEXT" == x"no" ; then
 AC_MSG_ERROR([Please install gettext])
 fi
 
+AC_CHECK_PROG(LIBTOOL,[libtool],[libtool],[no])
+if test x"$LIBTOOL" == x"no" ; then
+AC_MSG_ERROR([Please install libtool])
+fi
 
 CFG_CFLAGS+=" -fno-omit-frame-pointer -fno-math-errno -fno-signed-zeros"
 CFG_CFLAGS+=" -pthread -Wall"
@@ -217,7 +222,7 @@ PKG_3RD([esound],[no],
   [ . ])
 
 PKG_3RD([ffmpeg],[yes],
-  [ffmpeg-4.4],
+  [ffmpeg-5.1],
   [ libavutil/libavutil.a \
     libavcodec/libavcodec.a \
     libpostproc/libpostproc.a \